smbhaxCreator

Apparently my desktop CPU is so old and crusty (Intel Core 2 2.40 GHz dual core from 2006! woot) that it doesn't have the "Meltdown" and "Spectre" vulnerabilities that made all the news today. : o : P

Enjoying the series? Support the creator by becoming a patron.

Become a Patron
Wanna access your favorite comics offline? Download
TOP